This project has moved. For the latest updates, please go here.

The URI prefix is not recognized

Jul 29, 2009 at 3:38 PM

Hello,

 

i'm getting this error "The URI prefix is not recognized"

at the line 89 of the StartUpload() method of HttpFileUploader class.

"HttpWebRequest webRequest = (HttpWebRequest)WebRequest.Create(httpHandlerUrlBuilder.Uri);"

The uri of local file,

{file:///C:/Users/Francisco.UBISIGN.000/Documents/Visual Studio 2008/Projects/Silverlight/FileUpload/SilverlightMultiFileUploader_v3.0/mpost.SilverlightMultiFileUpload/Bin/Debug/HttpUploadHandler.ashx%3Ffile=Untitled.GRF&offset=0&last=True&first=True&param=}

 

Supposedly, WebRequest.Create supports this kind of Uri. What would be wrong then ?

 

Francisco

Coordinator
Jul 29, 2009 at 3:44 PM

Hi Francisco,

You need to run the application using a webserver, like IIS / Apache or the Visual Studio build in webserver. So the URL where the Silverlight application is loaded is something like: http://yourhost/SLpage.aspx. Don't open the page using your local file system, because then the application will try to access the webservice on c:\ (your local file system). And that won't work.

Good luck,
Michiel Post

Jun 18, 2010 at 10:00 PM

MP:

I'm having a similar problem.

 

The URI I'm getting is:

file:///C:/Documents and Settings/######/Desktop/SilverlightMultiFileUploader_v4.1/mpost.SilverlightMultiFileUpload/Bin/Debug/HttpUploadHandler.ashx

I'm using the VS2010 web server.  Any advice?

Thanx

</c>

 

 

 

 

 

Coordinator
Jun 18, 2010 at 11:19 PM

Run it from a webserver. Then Silverlight has no way of knowing anything like C:\etc