Can't get this to work :(

Feb 7, 2009 at 5:12 PM
Hi, i just can't get this to work.  Please could you run through this yourself setting this up with an existing website and document the steps involved as it doesn't work.  I tried adding the projects and then adding references in my website project but this game me conflicting assembly errors.  Therefore i removed the references and copied the xap file manually to my ClientBin directory and also copied the dlls into my bin directory.  Next i placed the http handler in my root and added the silverlight control to my test page.  Finally i added my Upload directory (which i know is writeable) and adding the setting in the web.config file.  If that wasn't enough to work out without any documentation, well it doesn't work.  When i run the website the silverlight control displays but then i get the error Upload Failed when clicking upload.

I can successfully get the sample to work so it could be possible that the silverlight project is looking for the wcf service files but i wish to use the http handler.

I'm not joking but i've spent the last 2 days with hardly a break trying to get this work but have run out of patience.  Really appreciate it if someone could help.

Thanks
Coordinator
Feb 7, 2009 at 6:24 PM
Edited Feb 7, 2009 at 6:24 PM
Hi,

Make sure to supply this InitParameter to the Silverlight control:
InitParameters="HttpUploader=true,other params...

This tells the Silverlight Uploader to user the HttpHandler. Also see the HttpHandler demo pages in the solution.

After that, try debugging the HttpHandler and see if it gets called.

Good luck.
Feb 7, 2009 at 9:50 PM
Hi, i've just tracked this down to a problem with iis.  If i run my website with the built in visual studio web server then everything works fine but as soon as i run it under iis 7 i get the "Upload Failed" error.  Anyone with any idea on how to fix this?
Feb 9, 2009 at 2:27 PM
I'm not quite sure how but i managed to get this to work.  I rewrote the http handler to my needs and moved it and it somehow worked.  My only possible explanation is that the http handler was not being recognized as part of my solution.  Anywayz all is good now.