Using for .Net framework 4.0

Oct 25, 2010 at 10:46 AM

Would it be possible to use the lovely tool for website configured for .net Framework 4.0?

It works great if I use 2.0, but if I switch 4.0 I got error

Can you help me? 

Internet Information Services 7.5

<fieldset><legend>Error Summary</legend>

HTTP Error 500.19 - Internal Server Error

The requested page cannot be accessed because the related configuration data for the page is invalid.

</fieldset>
<fieldset><legend>Detailed Error Information</legend>
Module IIS Web Core
Notification BeginRequest
Handler Not yet determined
Error Code 0x800700b7
Config Error There is a duplicate 'system.web.extensions/scripting/scriptResourceHandler' section defined
Config File \\?\C:\Users\dbsruany\Documents\Visual Studio 2010\WebSites\ProteinExpressionAutomation\Fileupload\mpost.SilverlightMultiFileUploadWeb\web.config
Requested URL http://pef.mbi.nus.edu.sg:8080/TTTTTTT/
Physical Path C:\Users\dbsruany\Documents\Visual Studio 2010\WebSites\ProteinExpressionAutomation\Fileupload\mpost.SilverlightMultiFileUploadWeb\
Logon Method Not yet determined
Logon User Not yet determined
</fieldset>
<fieldset><legend>Config Source</legend>
   13: 			<sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
   14: 				<section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>
   15: 				<sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
</fieldset>
<fieldset><legend>Links and More Information</legend>This error occurs when there is a problem reading the configuration file for the Web server or Web application. In some cases, the event logs may contain more information about what caused this error.

View more information »

</fieldset>

 


Coordinator
Oct 25, 2010 at 11:03 AM

You need to make your web.config .net 4 compatible. Just delete it and replace it with a valid .net 4 web.config versino.

Besides that, there's no problem. It can work with any .net version.

Oct 25, 2010 at 11:45 AM

Ok.>>>~

Thanks a lot