This project has moved and is read-only. For the latest updates, please go here.

HTTPS

May 19, 2010 at 6:00 PM
Edited May 19, 2010 at 6:50 PM

Hi,

I need this control to get working with Windows Authentication and Https. I`m getting error and the UploadHandler isn`t firing (in hanlder i write to file exception message in catch{ } but nothing is written after error) With anonymous access and without https everything is working fine. Please help!

Coordinator
May 19, 2010 at 7:04 PM

Using https, the HttpHandler is requested and authenticated just like any other request. It's the same as loading a webpage over https.

You can try debugging to see if the correct URL for the HttpHandler is called.

May 19, 2010 at 8:32 PM

so why did you create file readme_ssl.txt ?? You wrote there :


Want to use this control on SSL? You'll need to make the following changes

1) Change the Web.config
Find the following line:
<endpoint address="" binding="basicHttpBinding" contract="mpost.FileUploadServiceLibrary.IUploadService">

Add this configuration option to the line: bindingConfiguration="HttpsBinding"
The line will now look like this:
<endpoint address="" binding="basicHttpBinding" bindingConfiguration="HttpsBinding" contract="mpost.FileUploadServiceLibrary.IUploadService">


2) Change the Silverlight Source
Open the file WcfFileUploader.cs in the Classes folder in the mpost.SilverlightMultiFileUpload project.

//Enable this line for HTTPS
_client = new UploadService.UploadServiceClient();

And remove the following lines:
//Create WCF connection
//BasicHttpBinding binding = new BasicHttpBinding();
//EndpointAddress address = new EndpointAddress(new CustomUri("SilverlightUploadService.svc"));
//_client = new UploadService.UploadServiceClient(binding, address);

3) Change the ServiceReferences.ClientConfig

Change the mode in mode="Transport" for HTTPS
<security mode="None" />

Change your endpoint location in the correct URL for the endpoint:
<!--Make sure this URL is correct if you're using this on HTTPS-->
            <endpoint address="https://some-server/SilverlightUploadService.svc"


4) Recompile, this will result in a new Silverlight XAP file in the Web project

5) You're done. It now works on https



            

Coordinator
May 20, 2010 at 6:55 AM

The readme_ssl.txt was needed for using the WCF upload service over HTTPS. But in the latest release, the WCF service is removed.

You should download the latest checkin, SSL should work there:

http://slfileupload.codeplex.com/SourceControl/list/changesets